Troubleshooter - Mertik GV60

2.04 Gas supply and pilot light burner

Please check the following:

Receiver
- Batteries empty or weak? Replace with 4x AA (alkaline, non-rechargeable).

Presence of gas
Check the presence of gas by holding a lit lighter near the pilot burner during the normal start-up cycle or in manual mode*.

* Turn the oval knob on the gas control block to 'MAN', then push open the safety valve in the control block (e.g. with a screwdriver) and ignite the burner with a lighter. (See video above)
 
If the pilot does not light, go to Step 1.
If the pilot lights, go to Step 2.
 
Step 1: pilot has no gas
Now check the following:
- Is the gas tap open?
- Does gas flow into the gas control block? Check the pre-pressure at the measuring nipple on the valve.

Does gas flow out of the gas control block? Check this by disconnecting the pilot tube at the valve.

Is the pilot tube blocked (e.g. by dirt or a kink)?
 
Correct any problems and try to ignite the fire again.
- Is the control block still not passing gas? Then check the pilot flame adjustment screw (under the black cover). The seal must not be broken and the screw must be open (counterclockwise is open).

If the fire still will not ignite, replace the gas control block.

Step 2: pilot has gas but the electrode does not light it.

- Bend the tip of the right-angled electrode ±1mm upwards.
- Is the spark thin and reddish? If yes it's probably too weak

! After switching off the fire, the remote control is signal is locked for 120 seconds.
(60 seconds on older fires)

- Is the pilot flame too weak (dirty)? Disconnect the pilot tube and carefully remove the pilot nozzle from the assembly (do not drop it!). Clean the nozzle with compressed air (e.g. a bicycle pump).
 
Once any errors have been corrected, try to ignite the fire again.
 
If the fire still will not ignite, replace the gas control block.

Hide popup
Compare